Network equipment for wireless communication, processor for wireless communication, method performed by network equipment and user equipment for wireless communication.
Patent Information
- Application Number
- BR112025021053
- Authority / Receiving Office
- BR · BR
- Patent Type
- Applications
- Publication Date
- 2026-09-01
Smart Images

Figure 00000000_0000_ABST
Description
1 / 38 “NETWORK EQUIPMENT FOR WIRELESS COMMUNICATION, PROCESSOR FOR WIRELESS COMMUNICATION, METHOD PERFORMED BY NETWORK EQUIPMENT AND USER EQUIPMENT FOR WIRELESS COMMUNICATION” TECHNICAL AREA
[001] This disclosure relates to wireless communications and, more specifically, to techniques for sequence numbering with packet duplication and reordering for User Datagram Protocol (UDP) packets. Background of the Invention
[002] A wireless communications system may include one or more network communication devices, such as base stations or other network equipment (NE), which may support wireless communications to one or more user communication devices, which may also be known as user equipment (UE) or other suitable terminology. The wireless communications system may support wireless communications with one or more user communication devices by utilizing wireless communication system features (e.g., timing features (e.g., symbols, slots, subframes, frames, or the like) or frequency features (e.g., subcarriers, carriers, or the like).In addition, the wireless communications system can support wireless communications in various radio access technologies, including third-generation (3G) radio access technology, fourth-generation (4G) radio access technology, fifth-generation (5G) radio access technology, and other suitable radio access technologies besides 5G (e.g., sixth generation (6G)). Brief Description of the Invention
[003] The article “a” before an element is unrestricted and understood as referring to “at least one” of those elements or to “one or more” Petition 870250088639, dated 09 / 30 / 2025, page 59 / 112 2 / 38 of these elements. The terms “one,” “at least one,” “one or more,” and “at least one of one or more” may be interchangeable. As used herein, including in the claims, “or,” as used in a list of items (for example, a list of items preceded by a phrase such as “at least one of” or “one or more of” or “one or both of”) indicates an inclusive list, so that, for example, a list of at least one of A, B, or C means A or B or C or AB or AC or BC or ABC (i.e., A and B and C). Furthermore, as used herein, the phrase “based on” should not be interpreted as a reference to a closed set of conditions. For example, an example step described as “based on condition A” may be based on either condition A or condition B without departing from the scope of this disclosure. In other words, as used herein, the phrase “based on” should be interpreted in the same way as the phrase “based at least in part on.”Furthermore, as used herein, including in the claims, a "set" may include one or more elements.
[004] In one embodiment, an apparatus may be configured to support a means of establishing a communication session with a UE, the communication session comprising multipath internet connection functionality via UDP (Multipath Fast User Datagram Protocol) (MPQUIC); enabling routing, switching and splitting of UDP traffic between the UE and a proxy using MPQUIC functionality; and transmitting UDP packets between the UE and the proxy, the UDP packets encapsulated within datagram frames comprising an indication of an order of the datagram frames.
[005] In one embodiment, a method may be configured to support a means of establishing a communication session with a UE, the communication session comprising MPQUIC functionality; enabling the routing, switching, and splitting of UDP traffic. Petition 870250088639, dated 09 / 30 / 2025, page 60 / 112 3 / 38 between the UE and a proxy using the MPQUIC functionality; and transmit UDP packets between the UE and the proxy, the UDP packets encapsulated within datagram frames comprising an indication of an order of the datagram frames.
[006] In one embodiment, a processor may be configured to support a means of establishing a communication session with a UE, the communication session comprising MPQUIC functionality; enabling the routing, switching, and splitting of UDP traffic between the UE and a proxy using MPQUIC functionality; and transmitting UDP packets between the UE and the proxy, the UDP packets encapsulated within datagram frames comprising an indication of an order of the datagram frames.
[007] In one embodiment, an appliance can be configured to support a means of establishing a communication session with a proxy by means of a NE, the communication session comprising MPQUIC functionality, wherein the routing, switching and splitting of UDP traffic between the UE and a proxy are enabled using MPQUIC functionality.
[008] In one embodiment, a method can be configured to support a means of establishing a communication session with a proxy via a NE, the communication session comprising MPQUIC functionality, wherein the routing, switching, and splitting of UDP traffic between the UE and a proxy are enabled using MPQUIC functionality.
[009] In one embodiment, a processor can be configured to support a means of establishing a communication session with a proxy by means of a NE, the communication session comprising MPQUIC functionality, wherein routing, switching and splitting Petition 870250088639, dated 09 / 30 / 2025, page 61 / 112 4 / 38 of the UDP traffic between the UE and a proxy is enabled using the MPQUIC functionality. Brief Description of the Drawings
[010] Figure 1 illustrates an example of a wireless communications system in accordance with aspects of the present disclosure.
[011] Figure 2 illustrates an example of establishing a Multiple Access Protocol Data Unit (MA PDU) session in accordance with aspects of this disclosure.
[012] Figure 3 illustrates an example of the relationship between the HTTP / 3 datagram and the UDP proxy HTTP diagram payload according to aspects of this disclosure.
[013] Figure 4 illustrates an example of the relationship between the true UDP proxy payload and the UDP proxy HTTP datagram payload according to aspects of this disclosure.
[014] Figure 5 illustrates an example of one way of realizing the sequence number in accordance with aspects of the present disclosure.
[015] Figure 6 illustrates an example of a UE in accordance with aspects of this disclosure.
[016] Figure 7 illustrates an example of a processor in accordance with aspects of the present disclosure.
[017] Figure 8 illustrates an example of a NE in accordance with aspects of this disclosure.
[018] Figure 9 illustrates a flowchart of a method performed by an NE in accordance with aspects of this disclosure.
[019] Figure 10 illustrates a flowchart of a method executed by a UE in accordance with aspects of this disclosure. Detailed Description of the Invention
[020] In general, the subject discussed here is focused on Petition 870250088639, dated 09 / 30 / 2025, page 62 / 112 5 / 38 Sequence numbering techniques with packet duplication and reordering for UDP packets. Devices, methods, systems, processors and / or similar equipment are configured to perform various sequence numbering functions with packet duplication and reordering for UDP packets.
[021] In some cases, the upper layer routing functionality may use the UDP Multipath Quick Internet Connection (MPQUIC) to enable routing, switching, and splitting of UDP traffic between the UE and the User Plane Function (UPF) in an Access Traffic Routing, Switching, and Splitting (ATSSS) feature (e.g., as described in 3GPP TS 23.501 (incorporated herein by reference)). In certain cases, two transport modes are available when the routing functionality is the MPQUIC functionality “Datagram Mode 1” and “Datagram Mode 2” (e.g., as described in 3GPP TS 24.501 (incorporated herein by reference)). For example, the “Datagram Mode 1” transport mode may require sequence numbering for UDP packets within QUIC datagram frames (e.g., as defined in IETF RFC 9221 (incorporated herein by reference)).The topic discussed here concerns the numbering of the order of UDP packets encapsulated in QUIC datagram frames.
[022] In one embodiment, the solutions described herein provide an indicator (e.g., a sequence number) as the first octet of a QUIC datagram frame payload, indicating the bit size for order numbering, followed by the number. In one embodiment, one or more datagram frames are received from a different source, for example, different access technologies used to transmit a datagram frame (e.g., a transmitter using 3GPP and non-3GPP radio access technologies to transmit frames). Petition 870250088639, dated 09 / 30 / 2025, page 63 / 112 6 / 38 datagram). In certain embodiments, the solutions describe the predetermination of the bit number size, where the number is used to determine the order of QUIC datagram frames by negotiation before UDP packet transmission and / or by a decision, for example, the network provider's decision.
[023] The solutions described herein can be implemented by a UE and / or a NE (or a network function) and impact communications between a UE and an NE. Consequently, in certain embodiments, the solutions described herein increase the reliability, efficiency, and robustness of wireless communications between a UE and an NE, and specifically wireless communications using UDP packet transmission. Aspects of this disclosure are described in the context of a wireless communications system.
[024] Figure 1 illustrates an example of a wireless communications system (100), according to aspects of the present disclosure. The wireless communications system (100) may include one or more NEs (102), one or more UEs (104) and a central network (CN) (106). The wireless communications system (100) may support various radio access technologies. In some implementations, the wireless communications system (100) may be a 4G network, such as an LTE network or an LTE-Advanced (LTE-A) network. In some other implementations, the wireless communications system (100) may be an NR network, such as a 5G network, a 5G-Advanced (5G-A) network or a 5G ultra-wideband (5G-UWB) network. In other implementations, the wireless communications system (100) may be a combination of a 4G network and a 5G network, or other suitable radio access technology, including the Institute of Electrical and Electronics Engineers (IEEE) 802.11 (WiFi), IEEE 802.16 (WiMAX) and IEEE 802.20 standards.The wireless communications system (100) can support radio access technologies in addition to 5G, for example. Petition 870250088639, dated 09 / 30 / 2025, page 64 / 112 7 / 38 6G. In addition, the wireless communications system (100) can support technologies such as time division multiple access (TDMA), frequency division multiple access (FDMA) or code division multiple access (CDMA), etc.
[025] One or more NEs (102) may be dispersed over a geographical region to form the wireless communications system (100). One or more of the NEs (102) described herein may be, include, or be referred to as a network node, a base station, a network element, a network function, a network entity, a radio access network (RAN), a NodeB, an eNodeB (eNB), a next-generation NodeB (gNB), or other suitable terminology. A NE (102) and a UE (104) may communicate via a communication link, which may be a wireless or wired connection. For example, a NE (102) and a UE (104) may perform wireless communication (e.g., receive signaling, transmit signaling) via a Uu interface.
[026] A NE (102) may provide a geographic coverage area for which the NE (102) may support services for one or more UEs (104) within the geographic coverage area. For example, a NE (102) and a UE (104) may support wireless communication of service-related signals (e.g., voice, video, packet data, messaging, broadcasting, etc.) according to one or multiple radio access technologies. In some implementations, a NE (102) may be mobile, for example, a satellite associated with a non-terrestrial network (NTN). In some implementations, different geographic coverage areas (112) associated with the same or different radio access technologies may overlap, but the different geographic coverage areas may be associated with different NE (102).
[027] One or more UEs (104) may be dispersed across a geographical region of the wireless communications system (100). A UE (104) may include or be referred to as a remote unit, a mobile device, a Petition 870250088639, dated 09 / 30 / 2025, page 65 / 112 8 / 38 wireless device, a remote device, a subscriber device, a transmitting device, a receiving device, or some other suitable terminology. In some implementations, the UE (104) may be referred to as a unit, a station, a terminal, or a client, among other examples. Additionally, or alternatively, the UE (104) may be referred to as an Internet of Things (IoT) device, an Internet of Everything (IoE) device, or a machine-type communication (MTC) device, among other examples.
[028] A UE (104) may be able to support wireless communication directly with other UEs (104) via a communication link. For example, a UE (104) may support wireless communication directly with another UE (104) via a device-to-device (D2D) communication link. In some implementations, such as vehicle-to-vehicle (V2V), vehicle-to-everything (V2X), or cellular-to-V2X deployments, the communication link (114) may be referred to as a sidelink. For example, a UE (104) may support wireless communication directly with another UE (104) via a PC5 interface.
[029] An NE (102) can support communications with CN (106), or with another NE (102), or both. For example, an NE (102) can interact with another NE (102) or with CN (106) through one or more backhaul links (e.g., S1, N2, N2 or network interface). In some implementations, NEs (102) can communicate directly. In other implementations, NEs (102) can communicate with each other or indirectly (e.g., through CN (106)). In some implementations, one or more NEs (102) can include subcomponents, such as an access network entity, which can be an example of an access node controller (ANC). An ANC can communicate with one or more UEs (104) through one or more other access network transmission entities, which can be called radio heads, Petition 870250088639, dated 09 / 30 / 2025, p. 66 / 112 9 / 38 intelligent radio heads or transmit and receive points (TRPs).
[030] The CN (106) can support user authentication, access authorization, tracking, connectivity, and other access, routing, or mobility functions. The CN (106) can be an evolved packet core (EPC) or a 5G core (5GC), which can include a control plane entity that manages access and mobility (e.g., a mobility management entity (MME), an access and mobility management function (AMF)) and a user plane entity that routes packets or interconnects with external networks (e.g., a service gateway (SGW), a packet data network (PDN) gateway (P-GW), or a user plane function (UPF)). In some implementations, the control plane entity may manage non-accessible stratum (NAS) functions, such as mobility, authentication, and carrier management (e.g., data carriers, signal carriers, etc.) for one or more UEs (104) served by one or more NEs (102) associated with the CN (106).
[031] The CN (106) can communicate with a packet data network via one or more backhaul links (e.g., via an S1, N2, N2, or other network interface). The packet data network may include an application server. In some implementations, one or more UEs (104) can communicate with the application server. A UE (104) can establish a session (e.g., a Protocol Data Unit (PDU) session or similar) with the CN (106) via a NE (102). The CN (106) can route traffic (e.g., control information, data, and similar) between the UE (104) and the application server using the established session (e.g., the established PDU session). The PDU session can be an example of a logical connection between the UE (104) and the CN (106) (e.g., one or more network functions of the CN (106)).
[032] In the wireless communications system (100), the NEs (102) and Petition 870250088639, dated 09 / 30 / 2025, p. 67 / 112 10 / 38 UEs (104) can utilize wireless communication system resources (100) (e.g., timing resources (e.g., symbols, slots, subframes, frames, or similar) or frequency resources (e.g., subcarriers, carriers)) to perform various operations (e.g., wireless communications). In some implementations, NEs (102) and UEs (104) can support different resource structures. For example, NEs (102) and UEs (104) can support different frame structures. In some implementations, such as in 4G, NEs (102) and UEs (104) can support a single frame structure. In some other implementations, such as in 5G and among other suitable radio access technologies, NEs (102) and UEs (104) can support multiple frame structures (i.e., multiple frame structures). The NEs (102) and UEs (104) can support various frame structures based on one or more numerologies.
[033] One or more numerologies may be supported in the wireless communications system (100), and a numerology may include a subcarrier spacing and a cyclic prefix. A first numerology (e.g., =0) may be associated with a first subcarrier spacing (e.g., 15 kHz) and a normal cyclic prefix. In some implementations, the first numerology (e.g., =0) associated with the first subcarrier spacing (e.g., 15 kHz) may utilize one slot per subframe. A second numerology (e.g., =1) may be associated with a second subcarrier spacing (e.g., 30 kHz) and a normal cyclic prefix. A third numerology (e.g., =2) may be associated with a third subcarrier spacing (e.g., 60 kHz) and a normal cyclic prefix or an extended cyclic prefix.A fourth numerology (e.g., μ=3) can be associated with a fourth subcarrier spacing (e.g., 120 kHz) and a normal cyclic prefix. A fifth numerology (e.g., =4) can be associated with a fifth. Petition 870250088639, dated 09 / 30 / 2025, p. 68 / 112 11 / 38 subcarrier spacing (e.g., 240 kHz) and a normal cyclic prefix.
[034] A time interval of a resource (for example, a communication resource) can be organized according to frames (also called radio frames). Each frame can have a duration, for example, of 10 milliseconds (ms). In some implementations, each frame can include several subframes. For example, each frame can include 10 subframes, and each subframe can have a duration, for example, of 1 ms. In some implementations, each frame can have the same duration. In some implementations, each subframe of a frame can have the same duration.
[035] Additionally or alternatively, a time interval of a resource (e.g., a communication resource) may be organized according to slots. For example, a subframe may include a number (e.g., quantity) of slots. The number of slots in each subframe may also depend on one or more numerologies supported in the wireless communication system (100). For example, the first, second, third, fourth, and fifth numerologies (i.e., μ=0, μ=1, μ=2, μ=3, μ=4) associated with the respective subcarrier spacings of 15 kHz, 30 kHz, 60 kHz, 120 kHz, and 240 kHz may utilize a single slot per subframe, two slots per subframe, four slots per subframe, eight slots per subframe, and 16 slots per subframe, respectively. Each slot may include a number (e.g., quantity) of symbols (e.g., OFDM symbols). In some implementations, the number (e.g., quantity) of slots for a subframe may depend on numerology.For a normal cyclic prefix, a slot can include 14 symbols. For an extended cyclic prefix (e.g., applicable for 60 kHz subcarrier spacing), a slot can include 12 symbols. The relationship between the number of symbols per slot, the number of slots per subframe, and... Petition 870250088639, dated 09 / 30 / 2025, page 69 / 112 12 / 38 The number of slots per frame for a normal cyclic prefix and an extended cyclic prefix may depend on a numerology. It should be understood that the reference to a first numerology (e.g., μ=0) associated with a first subcarrier spacing (e.g., 15 kHz) may be used interchangeably between subframes and slots.
[036] In the wireless communications system (100), an electromagnetic (EM) spectrum can be divided, based on frequency or wavelength, into several classes, frequency bands, frequency channels, etc. By way of example, the wireless communications system (100) can support one or multiple operating frequency bands, such as the frequency band designations FR1 (410 MHz - 7.125 GHz), FR2 (24.25 GHz - 52.6 GHz), FR3 (7.125 GHz - 24.25 GHz), FR4 (52.6 GHz - 114.25 GHz), FR4a or FR4-1 (52.6 GHz - 71 GHz) and FR5 (114.25 GHz - 300 GHz). In some implementations, NEs (102) and UEs (104) can perform wireless communications in one or more of the operating frequency bands. In some implementations, FR1 can be used by NEs (102) and UEs (104), among other equipment or devices for cellular communications traffic (e.g., control information, data).In some implementations, FR2 can be used by NEs (102) and UEs (104), among other equipment or devices for short-range, high-data-rate capabilities.
[037] FR1 may be associated with one or multiple numerologies (e.g., at least three numerologies). For example, FR1 may be associated with a first numerology (e.g., =0), which includes a subcarrier spacing of 15 kHz; a second numerology (e.g., =1), which includes a subcarrier spacing of 30 kHz; and a third numerology (e.g., =2), which includes a subcarrier spacing of 60 kHz. FR2 may be associated with one or multiple numerologies (e.g., at least two numerologies). For example, FR2 Petition 870250088639, dated 09 / 30 / 2025, pp. 70 / 112 13 / 38 may be associated with a third numerology (e.g., μ=2), which includes a subcarrier spacing of 60 kHz; and a fourth numerology (e.g., μ=3), which includes a subcarrier spacing of 120 kHz.
[038] In one embodiment, the functionality in an ATSSS-enabled UE that allows routing, switching, and splitting multiple access (MA) PDU session traffic between 3GPP access and non-3GPP access is called “routing functionality”. An ATSSS-enabled UE may support high-layer routing functionalities, which operate above the IP layer (e.g., as described in 3GPP TS 23.501 (incorporated herein by reference)) having two high-layer routing functionalities where:
[039] The first high-layer routing functionality applies the Multipath Transmission Control Protocol (MPTCP) (e.g., IETF RFC 8684, incorporated herein by reference) and is referred to as the “MPTCP functionality” (see clause 5.32.6.2.1 of 3GPP TS 23.501). This routing functionality can be applied to route, switch, and split TCP traffic flows identified in ATSSS rules, for example, as defined in clause 5.32.8 of 3GPP TS 23.501. The MPTCP functionality in the UE can communicate with an associated MPTCP proxy functionality in the UPF, using the MPTCP protocol over the 3GPP and / or non-3GPP user plane.
[040] The second high-layer routing functionality applies the QUIC protocol (e.g., described in IETF RFC 9000, IETF RFC 9001, and IETF RFC 9002, each incorporated herein by reference) and its multipath extensions, and is referred to as the “MPQUIC functionality” (see clause 5.32.6.2.2 of 3GPP TS 23.501). This routing functionality can be applied to route, switch, and split UDP traffic flows identified in ATSSS rules, for example, as defined in the clause Petition 870250088639, dated 09 / 30 / 2025, pp. 71 / 112 14 / 38 5.32.8 of 3GPP TS 23.501. The MPQUIC functionality in UE can communicate with an associated MPQUIC proxy functionality in UPF, using the QUIC protocol and its multipath extensions over the 3GPP and / or non-3GPP user plane.
[041] In one embodiment, an ATSSS-capable UE can support low-layer routing functionalities, which operate below the IP layer. One type of low-layer routing feature is called “ATSSS-low-layer functionality” (ATSSSLL) (see clause 5.32.6.3.1 of 3GPP TS 23.501). This routing functionality can be applied to route, switch, and split various types of traffic, including TCP traffic, UDP traffic, Ethernet traffic, or similar. For example, the ATSSS-LL feature may be mandatory for MA Ethernet PDU sessions. In the network, there may be a UPF with ATSSS-LL support in the data path of the MA PDU session.
[042] In one embodiment, the MPQUIC functionality enables the routing, switching, and splitting of UDP traffic between the UE and the UPF, according to the ATSSS policy that the network may create. The operation of the MPQUIC functionality may be based on IETF RFC 9298 (incorporated herein by reference), which specifies how UDP traffic can be transferred between a client (UE) and a proxy (UPF) using the HTTP / 3 protocol IETF RFC 9114 (incorporated herein by reference). The HTTP / 3 protocol operates over the QUIC protocol (IETF RFC 9000, IETF RFC 9001, IETF RFC 9002), which supports simultaneous communication over multiple paths.
[043] MPQUIC functionality can be enabled for an MA PDU Session with type IPv4, IPv6, or IPv4v6, when both the UE and the network support this functionality. MPQUIC functionality may not be enabled when the MA PDU Session type is Ethernet. In one embodiment, MPQUIC functionality in the UE communicates with the Petition 870250088639, dated 09 / 30 / 2025, pp. 72 / 112 15 / 38 MPQUIC Proxy functionality on UPF (see Figure 4.2.10-1 of 3GPP TS 23.501) using the user plane of 3GPP access, or non-3GPP access, or both.
[044] In one embodiment, the MPQUIC functionality is composed of three components: a Quality of Service (QoS) flow selection and direction mode selection, an HTTP / 3 layer and a QUIC layer.
[045] In QoS flow selection and routing mode selection, UE initiates the establishment of one or more multipath QUIC connections after the establishment of the MA PDU session and, for each uplink UDP flow, selects a QoS flow (e.g., based on QoS rules), a routing mode, and a transport mode (e.g., based on ATSSS rules). This component in UPF selects, for each downlink UDP flow, a QoS flow, a routing mode, and a transport mode. In UE, this component is used in the uplink direction, while in UPF, this component is used in the downlink direction.
[046] The HTTP / 3 layer supports the HTTP / 3 protocol (e.g., as defined in RFC 9114 (incorporated herein by reference)) and the extensions defined in IETF RFC 9298 (incorporated herein by reference) for UDP proxy support over HTTP, in IETF RFC 9297 (incorporated herein by reference) for HTTP datagram support, and in IETF RFC 9220 (incorporated herein by reference) for Extended CONNECT support. The HTTP / 3 layer selects a multipath QUIC connection to be used for each UDP flow and allocates a new QUIC flow on that connection, which is associated with the UDP flow. It also configures this QUIC flow to apply a specific routing mode. In UE, the HTTP / 3 layer implements an HTTP / 3 client, while in UPF, it implements an HTTP / 3 proxy. Petition 870250088639, dated 09 / 30 / 2025, page 73 / 112 16 / 38
[047] The QUIC layer supports the QUIC protocol as defined in the applicable IETF specifications (e.g., IETF RFC 9000, IETF RFC 9001, and IETF RFC 9002) and the extensions defined in RFC 9221 (incorporated herein by reference) to support the transport of unreliable datagrams with QUIC and to support QUIC connections using multiple paths simultaneously. Figure 5.32.6.2.2-1 of 3GPP TS 23.501 shows the user plane protocol stack when the MPQUIC functionality is applied.
[048] In one embodiment, if the UE indicates that it is capable of supporting MPQUIC functionality, and the network agrees to enable MPQUIC functionality for the MA PDU session, then an associated MPQUIC proxy functionality will be enabled in the UPF for the MA PDU session.
[049] In this embodiment, the network allocates one IP address / prefix for the MA PDU session to the UE and two additional IP addresses / prefixes, called “MPQUIC link-specific multipath” addresses / prefixes – one associated with 3GPP access and the other associated with non-3GPP access. In the UE, these two IP addresses / prefixes are used by the MPQUIC functionality. Each “MPQUIC link-specific multipath” address / prefix assigned to the UE may not be routable through an N6 reference point. The MPQUIC functionality in the UE and the MPQUIC proxy functionality in the UPF can use the “MPQUIC link-specific multipath” addresses / prefixes to transmit UDP streams over non-3GPP access and over 3GPP access. The MPQUIC proxy functionality can use the MA PDU session IP address / prefix for communication with the final destination.
[050] In addition, the network sends MPQUIC proxy information to UE, such as a UPF IP address, a UDP port number, and the proxy type (e.g., “connect-udp”). This information Petition 870250088639, dated 09 / 30 / 2025, pp. 74 / 112 17 / 38 can be used by the UE to establish multipath QUIC connections with UPF, which implements the MPQUIC proxy functionality.
[051] Furthermore, after the MA Session PDU is established, the UE determines the number of multipath QUIC connections to be established with the UPF. The UE determines to establish at least as many multipath QUIC connections as the number of QoS flows in the MA Session PDU, for example, one multipath QUIC connection per QoS flow. Each multipath QUIC connection carries the UDP traffic mapped to a single QoS flow.
[052] In one embodiment, during the establishment of the QUIC connection, the UE and UPF negotiate QUIC transport parameters and indicate support for QUIC datagram frames and multipath support. They indicate support for QUIC datagram frames by providing the transport parameter “max_datagram_frame_size” with a non-zero value (see, for example, IETF RFC 9221) and indicate multipath support by providing the transport parameter “enable_multipath”. Furthermore, during the establishment of the QUIC connection, the QoS flow associated with that connection is determined. The UE sends the QUIC connection traffic through the QoS flow associated with the QUIC connection. This may allow the UPF to determine the QoS flow associated with the QUIC connection and select a QUIC connection to send downlink traffic from a QoS flow.
[053] After the QUIC connection is established, in some cases, the HTTP / 3 client on the UE and the HTTP / 3 proxy on the UPF negotiate the HTTP settings and indicate support for HTTP datagrams (see, for example, IETF RFC 9297) and support for Extended CONNECT (see, for example, IETF RFC 9220). To use the MPQUIC proxy for a UDP traffic stream, the UE sends an HTTP / 3 CONNECT request (see, for example, IETF RFC 9298) to the HTTP / 3 proxy on the UPF. Petition 870250088639, dated 09 / 30 / 2025, pp. 75 / 112 18 / 38
[054] The network can indicate to the UE the list of applications for which the MPQUIC functionality should be applied using the steering functionality component of an ATSSS rule (see, for example, clause 5.32.8 of 3GPP TS 23.501).
[055] In some cases, the MPQUIC resource supports multiple transport modes for transmitting a UDP stream between the UE and the UPF, see, for example, 3GPP TS 23.501. The PCF can select which of the transport modes will be applied to a UDP stream. The selected transport mode is provided to the UE and the UPF within the ATSSS rules.
[056] The datagram mode 1 transport mode (which may be an extension of the mode defined in RFC 9298) encapsulates UDP packets in QUIC datagram frames and provides unreliable transport, but with sequence numbering and packet reordering or deduplication. It can be applied to multiple UDP streams.
[057] The datagram mode 2 transport mode (e.g., defined in RFC 9298) encapsulates UDP packets within QUIC datagram frames and provides unreliable transport, without sequence numbering and without packet reordering or deduplication.
[058] The solutions described here are generally aimed at determining the numbering order of UDP packets encapsulated in QUIC datagram frames. In one embodiment, the solutions describe the use of an indicator as the first octet of the QUIC datagram frame payload, indicating the bit size for order numbering, followed by the number. In certain embodiments, the solutions describe the predetermination of the bit size, where the number is used to determine the order of QUIC datagram frames by negotiation before UDP packet transmission and / or a decision, such as the network provider's decision. Petition 870250088639, dated 09 / 30 / 2025, pp. 76 / 112 19 / 38
[059] Figure 2 illustrates an example of establishing an MA PDU session in accordance with aspects of this disclosure. In particular, Figure 2 shows the establishment of a PDU session requested by the UE (with the assumption that the UE is already registered on the network).
[060] In 1 (see message (202)), in one embodiment, UE (201) initiates the PDU session establishment procedure by including several information elements within the NAS message for the PDU session establishment procedure.
[061] In 2 (see message (204)), in one embodiment, when determining the session management function (SMF) (205), the AMF (203) constructs an Nsmf_PDUSession_CreateSMContext request with information elements to create a session management context (SM).
[062] In 3 (see message (206)), in one embodiment, when creating the SM context, the SMF (205) informs the AMF (203) by an Nsmf_PDUSession_CreateSMContext response.
[063] In 4 (see message (208)), in one embodiment, the SMF (205) initiates the procedure for establishing the N4 Session with the UPF (207) by sending N4 rules derived by the SMF (205) to the MA PDU session to instruct the UPF (207) to activate the MPQUIC functionality for this MA PDU Session.
[064] In 5 (see message (210)), in one embodiment, UPF (207) allocates the “MPQUIC link-specific multipath” addresses / prefixes from UE (201) and sends the “MPQUIC link-specific multipath” addresses / prefixes and MPQUIC proxy information to SMF (205).
[065] In 6 (see message (212)), in one embodiment, SMF (205) includes an indication “MA PDU Session accepted” in the Namf_Communication_N1N2MessageTransfer message to AMF (203) and indicates to AMF (203) that the SM N2 information included in this message should be Petition 870250088639, dated 09 / 30 / 2025, page 77 / 112 20 / 38 sent to the EU (201). The AMF (203) marks this PDU session as an MA PDU session based on the indication “MA PDU session accepted” received.
[066] In 7 (see message (214)), in one embodiment, UE (201) receives a PDU session establishment acceptance message, which indicates to UE (201) that the requested MA PDU session has been successfully established. This message includes the ATSSS rules for the MA PDU session, derived from SMF (205), the UE (201) “MPQUIC link-specific multipath” addresses / prefixes, and the MPQUIC proxy information.
[067] In 8 (see block (216)), in one embodiment, uplink and downlink data are established for the MA PDU session with UDP packets transmitting between UE (201) and UPF (207).
[068] Figure 3 illustrates an example of the relationship between the HTTP / 3 datagram and the UDP proxy HTTP diagram payload, according to aspects of the present disclosure. In one embodiment, in the data connection, the QUIC datagram frame can be used to provide demultiplexing and unreliable delivery when HTTP datagrams are transmitted over an HTTP / 3 connection. When used with HTTP / 3, in one embodiment, the datagram data field of the QUIC datagram frames uses the following format: HTTP / 3 Datagram { Room flow ID (i), HTTP datagram payload (..),} where the quaternary flow ID (302) is a variable-length integer representing the value of the bidirectional flow initiated by the client to which the datagram is associated, divided by four, for example, see IETF RFC 9297. In one embodiment, the datagram payload Petition 870250088639, dated 09 / 30 / 2025, pp. 78 / 112 21 / 38 HTTP (304), which is a QUIC datagram frame payload, is the HTTP / 3 datagram payload, which has semantics defined by the extension that uses HTTP datagrams.
[069] In one embodiment, when HTTP datagrams are associated with UDP proxy request streams, the HTTP datagram payload field has the following format: UDP proxy HTTP datagram payload { Context ID (i), UDP proxy payload (..),} where the context ID (306) is 62 bits, encoded with variable-length integers, for example, defined in clause 16 of IETF RFC 9000. In one embodiment, two transport modes are defined when the routing functionality is the MPQUIC functionality, and are identified by “Datagram Mode 1” and “Datagram Mode 2” (see, for example, 3GPP TS 24.501). In one embodiment, datagram mode 1 uses sequence numbering for UDP packets and is identified when the context ID bits are set to values greater than zero, for example, all set to the value “1” or similar. In one embodiment, datagram mode 2 does not require sequence numbering for UDP packets and is identified when the context ID bits are set to the value “0”. In one embodiment, the UDP proxy payload (308) is the UDP proxy HTTP datagram payload.
[070] Figure 4 illustrates an example of the relationship between the true UDP proxy payload and the UDP proxy HTTP datagram payload, according to aspects of the present disclosure. In one embodiment, for the sequence number (406) of the MPQUIC datagram frame payload, when the routing functionality is the functionality of Petition 870250088639, dated 09 / 30 / 2025, pp. 79 / 112 22 / 38 MPQUIC and the transport mode is datagram mode 1, meaning that all 62 bits of the context ID (402) are set to a value greater than zero, for example, the value “1”, an unsigned integer of 8, 16, 32, or 64 bits can be used. In one embodiment, the true UDP proxy payload (408) is the UDP proxy HTTP datagram payload. In one embodiment, the UDP proxy payload field (404) can have the format: UDP proxy payload { 8, 16, 32 or 64 bit sequence number, True UDP proxy payload (...),}.
[071] Figure 5 illustrates an example of one embodiment of the sequence number, according to aspects of the present disclosure. In one embodiment, a sequence number (502) can be indicated using 8, 16, 32 or 64 bits. In such an embodiment, the first octet (504) of the sequence number (502) can be an indicator of the size of the sequence number (502), where the remaining bits (506) represent the actual sequence number, as shown by the following format: Sequence number { Size of 8, 16, 32 or 64 bits, Number (..),}.
[072] In one embodiment, the size can always be a value, i.e., 8, 16, 32, or 64 for the ATSSS feature when MPQUIC is the driving functionality. In such an embodiment, indicating the size for the sequence number may not be necessary.
[073] Figure 6 illustrates an example of a UE (600) according to aspects of this disclosure. The UE (600) may include a processor Petition 870250088639, dated 09 / 30 / 2025, pp. 80 / 112 23 / 38 (602), a memory (604), a controller (606) and a transceiver (608). The processor (602), the memory (604), the controller (606) or the transceiver (608), or various combinations thereof or various components thereof, may be examples of means for carrying out various aspects of the present disclosure as described herein. These components may be coupled (e.g., operatively, communicatively, functionally, electronically, electrically) by means of one or more interfaces.
[074] The processor (602), memory (604), controller (606) or transceiver (608), or various combinations or components thereof, may be implemented in hardware (e.g., circuits). The hardware may include a processor, a digital signal processor (DSP), an application-specific integrated circuit (ASIC) or other programmable logic device, or any combination thereof configured as or otherwise supporting a means for performing the functions described in this disclosure.
[075] The processor (602) may include an intelligent hardware device (for example, a general-purpose processor, a DSP, a CPU, an ASIC, an FPGA, or any combination thereof). In some implementations, the processor (602) may be configured to operate the memory (604). In other implementations, the memory (604) may be integrated into the processor (602). The processor (602) may be configured to execute computer-readable instructions stored in memory (604) to enable the UE (600) to perform various functions of this disclosure.
[076] Memory (604) may include volatile or non-volatile memory. Memory (604) may store computer-readable and executable code, including instructions that, when executed by the processor (602), cause the UE (600) to perform various functions described herein. The code may be stored in a non-transient computer-readable medium, such as memory (604) or another type of memory. Computer-readable media include Petition 870250088639, dated 09 / 30 / 2025, pp. 81 / 112 24 / 38 both non-transient storage media and communication media, including any means that facilitates the transfer of a computer program from one place to another. A non-transient storage medium can be any available medium that can be accessed by a general-purpose or specific-purpose computer.
[077] In some implementations, the processor (602) and the memory (604) coupled to the processor (602) can be configured to make the UE (600) perform one or more of the functions described herein (for example, executing, by the processor (602), instructions stored in memory (604)). For example, the processor (602) can support wireless communication in the UE (600), according to the examples disclosed herein. The UE (600) can be configured to support a means of order numbering of the UDP packets encapsulated in the QUIC datagram frames.
[078] In one embodiment, the UE (600) can be configured to support a means of establishing a communication session with a UE, the communication session comprising MPQUIC functionality, enabling the routing, switching and splitting of UDP traffic between the UE and a proxy using MPQUIC functionality, and transmitting UDP packets between the UE and the proxy, the UDP packets encapsulated within datagram frames comprising an indication of an order of the datagram frames.
[079] In one embodiment, the indication of the order of the datagram frames is included in each datagram frame. In another embodiment, the indication of the order of the datagram frames is predetermined before the transmission of the datagram frames.
[080] In one embodiment, the indication of the order of the datagram frames that is predetermined before the transmission of the datagram frames is not included in the datagram frames, and in which a value Petition 870250088639, dated 09 / 30 / 2025, pages 82 / 112 25 / 38, determined based on a number of bits, is used to number the order of datagram frames.
[081] In one embodiment, the UE is an ATSSS device. In one embodiment, the communication session comprises an MA PDU session. In one embodiment, one or more datagram frames are received from a different source and ordered according to the indication.
[082] In one embodiment, the indication in each of the datagram frames is located in a first octet after a context ID within the payload of each of the datagram frames, wherein the indication comprises a 32-bit integer defined as a value that is greater than 0. In another embodiment, the indication in each of the datagram frames comprises a value determined based on a number of bits used to number the order of the datagram frames.
[083] In one embodiment, a transport mode is used to transmit the UDP packets. In one embodiment, the transport mode is datagram mode 1. In one embodiment, the proxy is a UPF. In one embodiment, the datagram frames are QUIC datagram frames.
[084] In one embodiment, the UE (600) can be configured to support a means of establishing a communication session with a proxy by means of an NE, comprising MPQUIC functionality, wherein the routing, switching and splitting of UDP traffic between the UE and a proxy are enabled using MPQUIC functionality. In one embodiment, the UE (600) can be configured to support a means of transmitting UDP packets to the proxy, encapsulated in datagram frames, comprising an indication of the order of the datagram frames. Petition 870250088639, dated 09 / 30 / 2025, page 83 / 112 26 / 38
[085] The controller (606) can manage input and output signals for the UE (600). The controller (606) can also manage peripherals not integrated into the UE (600). In some implementations, the controller (606) can utilize an operating system such as iOS®, ANDROID®, WINDOWS®, or other operating systems. In some implementations, the controller (606) can be implemented as part of the processor (602).
[086] In some implementations, the UE (600) may include at least one transceiver (608). In other implementations, the UE (600) may have more than one transceiver (608). The transceiver (608) may represent a wireless transceiver. The transceiver (608) may include one or more receiver chains (610), one or more transmitter chains (612), or a combination thereof.
[087] A receiving chain (610) may be configured to receive signals (e.g., control information, data, packets) via a wireless medium. For example, the receiving chain (610) may include one or more antennas to receive the signal via aerial or wireless transmission. The receiving chain (610) may include at least one amplifier (e.g., a low-noise amplifier (LNA)) configured to amplify the received signal. The receiving chain (610) may include at least one demodulator configured to demodulate the received signal and obtain the transmitted data by inverting the modulation technique applied during signal transmission. The receiving chain (610) may include at least one decoder to decode and process the demodulated signal to receive the transmitted data.
[088] A transmitter chain (612) can be configured to generate and transmit signals (e.g., control information, data, packets). The transmitter chain (612) can include at least one modulator to modulate data into a carrier signal, preparing the signal for wireless transmission. The at least one modulator can be configured to support a or Petition 870250088639, dated 09 / 30 / 2025, page 84 / 112 27 / 38 more techniques, such as amplitude modulation (AM), frequency modulation (FM) or digital modulation schemes, such as phase-shift keying (PSK) or quadrature amplitude modulation (QAM). The transmission chain (612) may also include at least one power amplifier configured to amplify the modulated signal to a power level appropriate for wireless transmission. The transmission chain (612) may also include one or more antennas to transmit the amplified signal into the air or wirelessly.
[089] Figure 7 illustrates an example of a processor (700) according to aspects of the present disclosure. The processor (700) may be an example of a processor configured to perform various operations according to the examples described herein. The processor (700) may include a controller (702) configured to perform various operations according to the examples described herein. The processor (700) may optionally include at least one memory (704), which may be, for example, an L1 / L2 / L3 cache. Additionally, or alternatively, the processor (700) may optionally include one or more arithmetic logic units (ALUs) (706). One or more of these components may be in electronic communication or otherwise coupled (e.g., operatively, communicatively, functionally, electronically, electrically) by means of one or more interfaces (e.g., buses).
[090] The processor (700) may be a processor chipset and include a protocol stack (e.g., a software stack) executed by the processor chipset to perform various operations (e.g., receive, get, retrieve, transmit, send, forward, store, determine, identify, access, write, read) as described in the examples herein. The processor chipset may include one or more cores, one or more caches (e.g., local memory or included in the processor chipset (e.g., the Petition 870250088639, dated 09 / 30 / 2025, page 85 / 112 28 / 38 processor (700)) or other memory (e.g., random access memory (RAM), read-only memory (ROM), dynamic RAM (DRAM), synchronous dynamic RAM (SDRAM), static RAM (SRAM), ferroelectric RAM (FeRAM), magnetic RAM (MRAM), resistive RAM (RRAM), flash memory, phase-change memory (PCM), and others).
[091] The controller (702) can be configured to manage and coordinate various operations (e.g., signaling, receiving, obtaining, retrieving, transmitting, outputting, forwarding, storing, determining, identifying, accessing, writing, reading) of the processor (700) to enable the processor (700) to support various operations, as described in the examples herein. For example, the controller (702) can operate as a control unit of the processor (700), generating control signals that manage the operation of various components of the processor (700). These control signals include enabling or disabling functional units, selecting data paths, initiating memory access, and coordinating the timing of operations.
[092] The controller (702) can be configured to fetch (e.g., get, retrieve, receive) instructions from memory (704) and determine the subsequent instruction(s) to be executed so that the processor (700) supports various operations as described in the examples herein. The controller (702) can be configured to track the memory address of instructions associated with memory (704). The controller (702) can be configured to decode instructions to determine the operation to be performed and the operands involved. For example, the controller (702) can be configured to interpret the instruction and determine the control signals to be sent to other components of the processor (700) so that the processor (700) supports various operations as described in the examples herein. Additionally, or alternatively, the controller Petition 870250088639, dated 09 / 30 / 2025, page 86 / 112 29 / 38 (702) can be configured to manage the data flow within the processor (700). The controller (702) can be configured to control the data transfer between registers, arithmetic logic units (ALUs), and other functional units of the processor (700).
[093] The memory (704) may include one or more caches (e.g., local memory or included in the processor (700) or other memory, such as RAM, ROM, DRAM, SDRAM, SRAM, MRAM, flash memory, etc. In some implementations, the memory (704) may reside within or on a processor chipset (e.g., local to the processor (700)). In some other implementations, the memory (704) may reside externally to the processor chipset (e.g., remote to the processor (700)).
[094] Memory (704) can store computer-readable and executable code, including instructions that, when executed by the processor (700), cause the processor (700) to perform various functions described in this document. The code can be stored in a non-transient computer-readable medium, such as system memory or other types of memory. The controller (702) and / or the processor (700) can be configured to execute computer-readable instructions stored in memory (704) to cause the processor (700) to perform various functions. For example, the processor (700) and / or the controller (702) can be coupled to memory (704); the processor (700), the controller (702), and memory (704) can be configured to perform various functions described in this document. In some examples, the processor (700) can include multiple processors and the memory (704) can include multiple memories.One or more of the multiple processors can be coupled to one or more of the multiple memories, which can be configured, individually or collectively, to perform various functions described herein.
[095] One or more ALUs (706) can be configured to Petition 870250088639, dated 09 / 30 / 2025, p. 87 / 112 30 / 38 support various operations, as described in the examples herein. In some implementations, one or more ALUs (706) may reside within or on a processor chipset (e.g., the processor (700)). In other implementations, one or more ALUs (706) may reside externally to the processor chipset (e.g., the processor (700)). One or more ALUs (706) may perform one or more calculations, such as addition, subtraction, multiplication, and division, on data. For example, one or more ALUs (706) may receive input operands and an operation code, which determines the execution of an operation. One or more ALUs (706) may be configured with a variety of logic and arithmetic circuits, including adders, subtractors, shifters, and logic gates, to process and manipulate the data according to the operation.Additionally, or alternatively, one or more ALUs (706) can support logical operations such as AND, OR, XOR, NOR and NAND, allowing one or more ALUs (706) to handle conditional operations, comparisons and bitwise operations.
[096] The processor (700) can support wireless communication according to the examples disclosed here. The processor (700) can be configured or operated to support a means of ordered numbering of the UDP packets encapsulated in the QUIC datagram frames.
[097] In one embodiment, the processor (700) can be configured to support a means of establishing a communication session with a UE, the communication session comprising MPQUIC functionality, enabling the routing, switching and splitting of UDP traffic between the UE and a proxy using MPQUIC functionality, and transmitting UDP packets between the UE and the proxy, the UDP packets encapsulated within datagram frames comprising an indication of an order of the datagram frames.
[098] In one embodiment, the indication of the order of Petition 870250088639, dated 09 / 30 / 2025, pp. 88 / 112 31 / 38 datagram frames are included in each datagram frame. In one embodiment, the order of the datagram frames is predetermined before the datagram frames are transmitted.
[099] In one embodiment, the indication of the order of the datagram frames that is predetermined before the transmission of the datagram frames is not included in the datagram frames, and in which a value determined based on a number of bits is used to number the order of the datagram frames.
[0100] In one embodiment, the UE is an ATSSS device. In one embodiment, the communication session comprises an MA PDU session. In one embodiment, one or more datagram frames are received from a different source and ordered according to the indication.
[0101] In one embodiment, the indication in each of the datagram frames is located in a first octet after a context ID within the payload of each of the datagram frames, wherein the indication comprises a 32-bit integer defined as a value that is greater than 0. In another embodiment, the indication in each of the datagram frames comprises a value determined based on a number of bits used to number the order of the datagram frames.
[0102] In one embodiment, a transport mode is used to transmit the UDP packets. In one embodiment, the transport mode is datagram mode 1. In one embodiment, the proxy is a UPF. In one embodiment, the datagram frames are QUIC datagram frames.
[0103] In one embodiment, the processor (700) can be configured to support a means of establishing a communication session with a proxy by means of a NE, comprising the functionality of Petition 870250088639, dated 09 / 30 / 2025, page 89 / 112 32 / 38 MPQUIC, in which the routing, switching, and splitting of UDP traffic between the UE and a proxy are enabled using the MPQUIC functionality. In one embodiment, the processor (700) can be configured to support a means of transmitting UDP packets to the proxy, encapsulated in datagram frames, comprising an indication of the order of the datagram frames.
[0104] Figure 8 illustrates an example of an NE (800) according to aspects of the present disclosure. The NE (800) may include a processor (802), a memory (804), a controller (806) and a transceiver (808). The processor (802), the memory (804), the controller (806) or the transceiver (808), or various combinations thereof or various components thereof, may be examples of means for carrying out various aspects of the present disclosure as described herein. These components may be coupled (e.g., operatively, communicatively, functionally, electronically, electrically) by means of one or more interfaces.
[0105] The processor (802), memory (804), controller (806) or transceiver (808), or various combinations or components thereof, may be implemented in hardware (e.g., circuits). The hardware may include a processor, a digital signal processor (DSP), an application-specific integrated circuit (ASIC) or other programmable logic device, or any combination thereof configured as or otherwise supporting a means for performing the functions described in this disclosure.
[0106] The processor (802) may include an intelligent hardware device (e.g., a general-purpose processor, a DSP, a CPU, an ASIC, an FPGA, or any combination thereof). In some implementations, the processor (802) may be configured to operate the memory (804). In other implementations, the memory (804) may be integrated into the processor (802). The processor (802) may be configured to execute Petition 870250088639, dated 09 / 30 / 2025, pages 90 / 112 33 / 38 computer-readable instructions stored in memory (804) to enable the NE (800) to perform various functions of this disclosure.
[0107] Memory (804) may include volatile or non-volatile memory. Memory (804) may store computer-readable and executable code, including instructions that, when executed by the processor (802), cause the NE (800) to perform various functions described in this document. The code may be stored on a non-transient computer-readable medium, such as memory (804) or another type of memory. Computer-readable media include both non-transient storage media and communication media, including any medium that facilitates the transfer of a computer program from one place to another. A non-transient storage medium may be any available medium that can be accessed by a general-purpose or specific-purpose computer.
[0108] In some implementations, the processor (802) and the memory (804) coupled to the processor (802) can be configured to make the NE (800) perform one or more of the functions described here (for example, executing, by the processor (802), instructions stored in memory (804)). For example, the processor (802) can support wireless communication in the NE (800), according to the examples disclosed here.
[0109] In one embodiment, the NE (800) can be configured to support a means of establishing a communication session with a UE, the communication session comprising MPQUIC functionality, enabling the routing, switching and splitting of UDP traffic between the UE and a proxy using MPQUIC functionality, and transmitting UDP packets between the UE and the proxy, the UDP packets encapsulated within datagram frames comprising an indication of an order of the datagram frames.
[0110] In one embodiment, the indication of the order of Petition 870250088639, dated 09 / 30 / 2025, pp. 91 / 112 34 / 38 datagram frames are included in each datagram frame. In one embodiment, the order of the datagram frames is predetermined before the datagram frames are transmitted.
[0111] In one embodiment, the indication of the order of the datagram frames that is predetermined before the transmission of the datagram frames is not included in the datagram frames, and in which a value determined based on a number of bits is used to number the order of the datagram frames.
[0112] In one embodiment, the UE is an ATSSS device. In one embodiment, the communication session comprises an MA PDU session. In one embodiment, one or more datagram frames are received from a different source and ordered according to the indication.
[0113] In one embodiment, the indication in each of the datagram frames is located in a first octet after a context ID within the payload of each of the datagram frames, wherein the indication comprises a 32-bit integer defined as a value that is greater than 0. In another embodiment, the indication in each of the datagram frames comprises a value determined based on a number of bits used to number the order of the datagram frames.
[0114] In one embodiment, a transport mode is used to transmit the UDP packets. In one embodiment, the transport mode is datagram mode 1. In one embodiment, the proxy is a UPF. In one embodiment, the datagram frames are QUIC datagram frames.
[0115] The controller (806) can manage input and output signals for the NE (800). The controller (806) can also manage peripherals not integrated into the NE (800). In some implementations, the controller (806) Petition 870250088639, dated 09 / 30 / 2025, pages 92 / 112 35 / 38 can use an operating system such as iOS®, ANDROID®, WINDOWS® or other operating systems. In some implementations, the controller (806) may be implemented as part of the processor (802).
[0116] In some implementations, the NE (800) may include at least one transceiver (808). In other implementations, the NE (800) may have more than one transceiver (808). The transceiver (808) may represent a wireless transceiver. The transceiver (808) may include one or more receiver chains (810), one or more transmitter chains (812), or a combination thereof.
[0117] A receiving chain (810) may be configured to receive signals (e.g., control information, data, packets) via a wireless medium. For example, the receiving chain (810) may include one or more antennas to receive the signal via wireless or wireless transmission. The receiving chain (810) may include at least one amplifier (e.g., a low-noise amplifier (LNA)) configured to amplify the received signal. The receiving chain (810) may include at least one demodulator configured to demodulate the received signal and obtain the transmitted data by inverting the modulation technique applied during signal transmission. The receiving chain (810) may include at least one decoder to decode and process the demodulated signal to receive the transmitted data.
[0118] A transmitter chain (812) can be configured to generate and transmit signals (e.g., control information, data, packets). The transmitter chain (812) may include at least one modulator to modulate data into a carrier signal, preparing the signal for transmission over a wireless medium. The at least one modulator may be configured to support one or more techniques, such as amplitude modulation (AM), frequency modulation (FM), or digital modulation schemes such as phase-shift keying (PSK) or quadrature amplitude modulation (QAM). The chain Petition 870250088639, dated 09 / 30 / 2025, pp. 93 / 112 36 / 38 transmitter (812) may also include at least one power amplifier configured to amplify the modulated signal to a power level appropriate for wireless transmission. The transmitter chain (812) may also include one or more antennas for transmitting the amplified signal into the air or wirelessly.
[0119] Figure 9 illustrates a flowchart of a method according to aspects of the present disclosure. The method operations can be implemented by a NE, as described herein. In some implementations, the NE may execute a set of instructions to control the NE's functional elements to perform the described functions.
[0120] In (902), the method can establish a communication session with a UE, wherein the communication session comprises the MPQUIC functionality. The operations of (902) can be performed according to the examples described here. In some implementations, aspects of the operations of (902) can be performed by a NE, as described with reference to Figure 8.
[0121] In (904), the method can enable routing, switching, and splitting of UDP traffic between the UE and a proxy using MPQUIC functionality. The operations of (904) can be performed according to the examples described here. In some implementations, aspects of the operations of (904) can be performed by a NE, as described with reference to Figure 8.
[0122] In (906), the method can transmit UDP packets between the UE and the proxy, the UDP packets being encapsulated in datagram frames, containing an indication of the order of the datagram frames. The operations of (906) can be executed according to the examples described here. In some implementations, aspects of the operations of (906) can be executed by a NE, as described with reference to Figure 8. Petition 870250088639, dated 09 / 30 / 2025, pp. 94 / 112 37 / 38
[0123] It should be noted that the method described here describes one possible implementation, and that the operations and steps may be rearranged or modified in other ways and that other implementations are possible.
[0124] Figure 10 illustrates a flowchart of a method according to aspects of the present disclosure. The method operations can be implemented by a UE as described herein. In some implementations, the UE may execute a set of instructions to control the UE's functional elements to perform the described functions.
[0125] In (1002), the method can establish a communication session with a proxy through a NE, wherein the communication session comprises the MPQUIC functionality, in which the routing, switching, and splitting of UDP traffic between the UE and a proxy are enabled using the MPQUIC functionality. The operations of (1002) can be performed according to the examples described here. In some implementations, aspects of the operations of (1002) can be performed by a UE, as described with reference to Figure 6.
[0126] In (1004), the method can transmit UDP packets to the proxy, the UDP packets being encapsulated in datagram frames, containing an indication of the order of the datagram frames. The operations of (1004) can be executed according to the examples described here. In some implementations, aspects of the operations of (1004) can be executed by a UE, as described with reference to Figure 6.
[0127] It should be noted that the method described here describes one possible implementation, and that the operations and steps may be rearranged or modified in other ways and that other implementations are possible.
[0128] The description presented here is intended to allow a person Petition 870250088639, dated 09 / 30 / 2025, pages 95 / 112 38 / 38 with common technical knowledge in the field create or use this disclosure. Several modifications to the disclosure will be evident to a person with common technical knowledge in the field, and the generic principles defined here can be applied to other variations without departing from the scope of the disclosure. Thus, the disclosure is not limited to the examples and projects described here, but should be given a broader scope, consistent with the principles and new features disclosed here. Petition 870250088639, dated 09 / 30 / 2025, pages 96 / 112
Claims
1 / 5 Claims 1. NETWORK EQUIPMENT (102; 800) FOR WIRELESS COMMUNICATION, characterized by comprising: at least one memory (804); and at least one processor (802) coupled with the at least one memory (804) and configured to cause the network equipment (102; 800) to: - establish (902) a communication session with a user equipment (104; 201; 600), the communication session comprising user fast datagram protocol - UDP multipath - MPQUIC internet connection functionality; - allow (904) the routing, switching and splitting of user datagram protocol - UDP traffic between the user equipment (104; 201; 600) and a proxy using MPQUIC functionality; and - transmit (906) user datagram protocol packets - UDP between user equipment (104; 201;600) and the proxy, the User Datagram Protocol (UDP) packets encapsulated within datagram frames comprising an indication of an order of the datagram frames.
2. NETWORK EQUIPMENT (102; 800), according to claim 1, characterized in that the indication of the order of the datagram frames is included in each datagram frame.
3. NETWORK EQUIPMENT (102; 800), according to claim 1, characterized in that the order of the datagram frames is predetermined before the transmission of the datagram frames.
4. NETWORK EQUIPMENT (102; 800), according to claim 3, characterized by the indication of the order of the datagram frames which is predetermined before the transmission of the datagram frames not being included in the datagram frames, and wherein a value determined based on a number of bits (506) is used to number the order of the datagram frames.
5. NETWORK EQUIPMENT (102; 800), according to claim 1, characterized in that the user equipment (104; 201; 600) is an ATSSS access traffic routing, switching and division device.
6. NETWORK EQUIPMENT (102; 800), according to claim 1, characterized in that the communication session comprises a protocol data unit session - multiple access PDU - MA.
7. NETWORK EQUIPMENT (102; 800), according to claim 1, characterized in that one or more datagram frames are received from a different source and ordered according to the indication.
8. NETWORK EQUIPMENT (102; 800), according to claim 7, characterized in that the indication in each of the datagram frames is located in a first octet after a context ID (306) within a payload (304) of each of the datagram frames, wherein the indication comprises a 32-bit integer defined as a value that is greater than 0.
9. NETWORK EQUIPMENT (102; 800), according to claim 8, characterized in that the indication in each of the datagram frames comprises a value determined based on a number of bits used to number the order of the datagram frames.
10. NETWORK EQUIPMENT (102; 800), according to claim 1, characterized by a transport mode being used to transmit user datagram protocol packets - UDP.
11. NETWORK EQUIPMENT (102; 800), according to claim 10, characterized in that the mode of transport is the mode of Petition 870250088639, dated 09 / 30 / 2025, page 98 / 112 3 / 5 datagram 1.
12. NETWORK EQUIPMENT (102; 800), according to claim 1, characterized in that the proxy is a UPF user plane function (207).
13. NETWORK EQUIPMENT (102; 800), according to claim 1, characterized in that the datagram frames are QUIC datagram frames.
14. WIRELESS COMMUNICATION PROCESSOR (700), characterized by comprising: at least one controller (702) coupled with at least one memory (704) and configured to cause the processor (700) to: - establish a communication session with a user device (104; 201; 600), the communication session comprising user fast datagram protocol - UDP multipath - MPQUIC internet connection functionality; - allow routing, switching and splitting of user datagram protocol - UDP traffic between the user device (104; 201; 600) and a proxy using MPQUIC functionality; and - transmit user datagram protocol - UDP packets between the user device (104; 201; 600) and the proxy, the user datagram protocol - UDP packets encapsulated within datagram frames comprising an indication of an order of the datagram frames.
15. PROCESSOR (700), according to claim 14, characterized in that the indication of the order of the datagram frames is included in each datagram frame.
16. PROCESSOR (700), according to claim 14, characterized in that the order of the datagram frames is indicated before the transmission of the datagram frames.
17. METHOD PERFORMED BY A NETWORK EQUIPMENT (102; 800), characterized by the method comprising: - establishing (902) a communication session with a user equipment (104; 201; 600), the communication session comprising the functionality of the user fast datagram protocol - UDP multipath - MPQUIC internet connection; - enabling (904) the routing, switching and splitting of user datagram protocol - UDP traffic between the user equipment (104; 201; 600) and a proxy using the MPQUIC functionality; and - transmitting (906) user datagram protocol - UDP packets between the user equipment (104; 201; 600) and the proxy, the user datagram protocol - UDP packets encapsulated within datagram frames comprising an indication of an order of the datagram frames.
18. METHOD, according to claim 17, characterized in that the order of the datagram frames is indicated in each datagram frame.
19. METHOD, according to claim 17, characterized in that the order of the datagram frames is predetermined before the transmission of the datagram frames.
20. USER EQUIPMENT (104; 201; 600) FOR WIRELESS COMMUNICATION, characterized by comprising: at least one memory (604); and at least one processor (602) coupled with at least one memory (604) and configured to cause the user equipment (104; 201 600): - to establish (1002) a communication session with a Petition 870250088639, dated 09 / 30 / 2025, page.100 / 112 5 / 5 proxy via a network device (102; 800), the communication session comprising the multipath User Datagram Protocol - UDP - MPQUIC internet connection functionality, wherein the routing, switching and splitting of User Datagram Protocol - UDP traffic between the user device (104; 201; 600) and a proxy are enabled using the MPQUIC functionality; and - transmit (1004) User Datagram Protocol - UDP packets to the proxy, the User Datagram Protocol - UDP packets encapsulated within datagram frames comprising an indication of an order of the datagram frames. Petition 870250088639, dated 09 / 30 / 2025, pp. 101 / 112.